Setting up fresh ICTFAX

Post queries and issues that you found during ictfax installation

Re: Setting up fresh ICTFAX

Postby falak » Sat Jun 15, 2013 5:50 am

If you want to go to "default" directory from root then following will be the path:

Code: Select all
cd /usr/ictfax/sites/default


Now assuming if you are currently in the "ictfax" directory. then you would do:

Code: Select all
cd sites/default

no slash '/' before sites.

If that is successful, then do following:

Code: Select all
mv default.settings.php settings.php
chmod 777 settings.php
mkdir files
chmod 777 files


Once the installation is complete then change the permission of these file and directory from 777 to 755 (or 766) for security reasons.
falak
Site Admin
 
Posts: 168
Joined: Tue Jan 17, 2012 7:33 am

Re: Setting up fresh ICTFAX

Postby falak » Wed Jul 03, 2013 10:33 am

This is strange. Did you have ictfax folder inside usr? :shock:
falak
Site Admin
 
Posts: 168
Joined: Tue Jan 17, 2012 7:33 am

Re: Setting up fresh ICTFAX

Postby falak » Thu Jul 04, 2013 7:09 am

cd /src
wget http://sourceforge.net/projects/ictfax/ ... -2.1.1.zip
cd /usr/src
unzip /src/ictfax-2.1.1.zip


Above quoted lines show that your ictfax folder is not in "/usr". It is actually in '/usr/src" that is why you are unable to execute the previous commands.

Please follow the installation instruction and see 4.2: Frontend / Web GUI part of the installation.
falak
Site Admin
 
Posts: 168
Joined: Tue Jan 17, 2012 7:33 am

Re: Setting up fresh ICTFAX

Postby falak » Tue Jul 09, 2013 6:30 am

definitely :)
falak
Site Admin
 
Posts: 168
Joined: Tue Jan 17, 2012 7:33 am

Re: Setting up fresh ICTFAX

Postby falak » Fri Jul 12, 2013 2:55 am

I am afraid you are not following the documentation. This is mentioned in the documentation that ...

Note:Following contributed modules should be enabled.
1.Chaos Tools
2.Features
3.Feeds
4.Countries
5.Mailhandler (All are required)
6.Job Scheduler
7.Strongarm
8.Views


And the error you are running into clearly shows

Field 'country' doesn't have a default value.


That means you have not enabled countries module and other contributed modules.
falak
Site Admin
 
Posts: 168
Joined: Tue Jan 17, 2012 7:33 am

Re: Setting up fresh ICTFAX

Postby falak » Sat Jul 13, 2013 7:56 am

I think following posts might help for configuration with cisco CUCM.
http://forum.ictfax.org/viewtopic.php?f=8&t=2461&sid=c0e638fb276111deeecc4d6c6ce50150

Also try to contact the people involved in that post.
falak
Site Admin
 
Posts: 168
Joined: Tue Jan 17, 2012 7:33 am

Re: Setting up fresh ICTFAX

Postby msalaque » Mon Jul 15, 2013 11:11 am

I am following this thread to install my first ICTFAX .
I am stack at

12. goto administrator => mailhandler => Add Mailbox and set following fields

I put all the values according to the installation guide but got error

Warning: imap_open(): Couldn't open stream /var/spool/mail/freeswitch in MailhandlerPhpImapRetrieve->open_mailbox() (line 121 of /usr/ictfax/sites/all/modules/mailhandler/modules/mailhandler_php_imap/plugins/mailhandler/retrieve/MailhandlerPhpImapRetrieve.class.php).

I selected :
protocol : local Mbox file
domain : empty [But it is automatically filled with server IP]
Port : emtpy
Username: freeswitch
password: xxxxxx [ freeswtich linux user password]
Extra commands : /notls

Any help ?


my sendmail is running properly with proper MX . i tested .


my setup inv:
CentOS release 6.4
PHP 5.3.3 (cli) (built: Jul 12 2013 20:35:47)
msalaque
 
Posts: 3
Joined: Thu Jun 28, 2012 2:44 am


Return to Installation

Who is online

Users browsing this forum: No registered users and 1 guest

cron