Plivo failing on centos 64

Post queries and issues that you found during ictfax installation

Re: Plivo failing on centos 64

Postby falak » Sat Aug 03, 2013 7:13 am

This is strange error. I could not exactly tell what is the issue here. I have installed ictfax and plivo on CENTOS 6.* many times. Never got this error. I hope you have installed all the dependencies.
falak
Site Admin
 
Posts: 166
Joined: Tue Jan 17, 2012 7:33 am

Re: Plivo failing on centos 64

Postby nasir » Sat Oct 05, 2013 9:28 am

Actually Plivo have its own script for installation which automatically install all missting dependencies. and we have never got this error, but anyway we have included libevent-devel in list of ictfax dependices.

Anything else we can help ?
nasir
 
Posts: 55
Joined: Mon Sep 09, 2013 12:11 pm

Re: Plivo failing on centos 64

Postby ygbsm » Sun Jan 05, 2014 10:06 am

I'm having the same issue with Plivo installation (Step 4) in debian...installation failed.
ygbsm
 
Posts: 1
Joined: Sun Jan 05, 2014 9:39 am

Re: Plivo failing on centos 64

Postby fikret » Mon Jan 06, 2014 10:37 pm

i have also problem with installation of ictfax on CentOS 6.5 x64 AND CentOS 6.5 x32

on step
./plivo_install.sh /usr/local/plivo
Please help

on CentOS 6.5 x64

Code: Select all
Installed /usr/lib/python2.6/site-packages/pip-1.5-py2.6.egg
Processing dependencies for pip
Finished processing dependencies for pip
New python executable in /usr/local/plivo/bin/python
Installing setuptools, pip...
  Complete output from command /usr/local/plivo/bin/python -c "import sys, pip; pip...ll\"] + sys.argv[1:])" setuptools pip:
  Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/usr/lib/python2.6/site-packages/virtualenv-1.11-py2.6.egg/virtualenv_support/pip-1.5-py2.py3-none-any.whl/pip/__init__.py", line 9, in <module>
  File "/usr/lib/python2.6/site-packages/virtualenv-1.11-py2.6.egg/virtualenv_support/pip-1.5-py2.py3-none-any.whl/pip/log.py", line 8, in <module>
  File "/usr/lib/python2.6/site-packages/virtualenv-1.11-py2.6.egg/virtualenv_support/setuptools-2.0.2-py2.py3-none-any.whl/pkg_resources.py", line 2696, in <module>
  File "/usr/lib/python2.6/site-packages/virtualenv-1.11-py2.6.egg/virtualenv_support/setuptools-2.0.2-py2.py3-none-any.whl/pkg_resources.py", line 429, in __init__
  File "/usr/lib/python2.6/site-packages/virtualenv-1.11-py2.6.egg/virtualenv_support/setuptools-2.0.2-py2.py3-none-any.whl/pkg_resources.py", line 443, in add_entry
  File "/usr/lib/python2.6/site-packages/virtualenv-1.11-py2.6.egg/virtualenv_support/setuptools-2.0.2-py2.py3-none-any.whl/pkg_resources.py", line 1722, in find_in_zip
  File "/usr/lib/python2.6/site-packages/virtualenv-1.11-py2.6.egg/virtualenv_support/setuptools-2.0.2-py2.py3-none-any.whl/pkg_resources.py", line 1298, in has_metadata
  File "/usr/lib/python2.6/site-packages/virtualenv-1.11-py2.6.egg/virtualenv_support/setuptools-2.0.2-py2.py3-none-any.whl/pkg_resources.py", line 1614, in _has
  File "/usr/lib/python2.6/site-packages/virtualenv-1.11-py2.6.egg/virtualenv_support/setuptools-2.0.2-py2.py3-none-any.whl/pkg_resources.py", line 1488, in _zipinfo_name
AssertionError: /usr/lib/python2.6/site-packages/virtualenv-1.11-py2.6.egg/EGG-INFO/PKG-INFO is not a subpath of /usr/lib/python2.6/site-packages/virtualenv-1.11-py2.6.egg/virtualenv_support/setuptools-2.0.                               2-py2.py3-none-any.whl/
----------------------------------------
...Installing setuptools, pip...done.
Traceback (most recent call last):
  File "/usr/bin/virtualenv", line 9, in <module>
    load_entry_point('virtualenv==1.11', 'console_scripts', 'virtualenv')()
  File "/usr/lib/python2.6/site-packages/virtualenv-1.11-py2.6.egg/virtualenv.py", line 820, in main
    symlink=options.symlink)
  File "/usr/lib/python2.6/site-packages/virtualenv-1.11-py2.6.egg/virtualenv.py", line 988, in create_environment
    install_wheel(to_install, py_executable, search_dirs)
  File "/usr/lib/python2.6/site-packages/virtualenv-1.11-py2.6.egg/virtualenv.py", line 956, in install_wheel
    'PIP_NO_INDEX': '1'
  File "/usr/lib/python2.6/site-packages/virtualenv-1.11-py2.6.egg/virtualenv.py", line 898, in call_subprocess
    % (cmd_desc, proc.returncode))
OSError: Command /usr/local/plivo/bin/python -c "import sys, pip; pip...ll\"] + sys.argv[1:])" setuptools pip failed with error code 1
./plivo_install.sh: line 185: /usr/local/plivo/bin/activate: No such file or directory
Wheel installs require setuptools >= 0.8 for dist-info support.
pip's wheel support requires setuptools >= 0.8 for dist-info support.
Storing debug log for failure in /root/.pip/pip.log
Wheel installs require setuptools >= 0.8 for dist-info support.
pip's wheel support requires setuptools >= 0.8 for dist-info support.
Storing debug log for failure in /root/.pip/pip.log



Installation failed !





on CentOS 6.5 x32

Code: Select all
Using /usr/lib/python2.6/site-packages/pip-1.5-py2.6.egg
Processing dependencies for pip
Finished processing dependencies for pip
New python executable in /usr/local/plivo/bin/python
Installing setuptools, pip...
  Complete output from command /usr/local/plivo/bin/python -c "import sys, pip; pip...ll\"] + sys.argv[1:])" setuptools pip:
  Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/usr/lib/python2.6/site-packages/virtualenv-1.11-py2.6.egg/virtualenv_support/pip-1.5-py2.py3-none-any.whl/pip/__init__.py", line 9, in <module>
  File "/usr/lib/python2.6/site-packages/virtualenv-1.11-py2.6.egg/virtualenv_support/pip-1.5-py2.py3-none-any.whl/pip/log.py", line 8, in <module>
  File "/usr/lib/python2.6/site-packages/virtualenv-1.11-py2.6.egg/virtualenv_support/setuptools-2.0.2-py2.py3-none-any.whl/pkg_resources.py", line 2696, in <module>
  File "/usr/lib/python2.6/site-packages/virtualenv-1.11-py2.6.egg/virtualenv_support/setuptools-2.0.2-py2.py3-none-any.whl/pkg_resources.py", line 429, in __init__
  File "/usr/lib/python2.6/site-packages/virtualenv-1.11-py2.6.egg/virtualenv_support/setuptools-2.0.2-py2.py3-none-any.whl/pkg_resources.py", line 443, in add_entry
  File "/usr/lib/python2.6/site-packages/virtualenv-1.11-py2.6.egg/virtualenv_support/setuptools-2.0.2-py2.py3-none-any.whl/pkg_resources.py", line 1722, in find_in_zip
  File "/usr/lib/python2.6/site-packages/virtualenv-1.11-py2.6.egg/virtualenv_support/setuptools-2.0.2-py2.py3-none-any.whl/pkg_resources.py", line 1298, in has_metadata
  File "/usr/lib/python2.6/site-packages/virtualenv-1.11-py2.6.egg/virtualenv_support/setuptools-2.0.2-py2.py3-none-any.whl/pkg_resources.py", line 1614, in _has
  File "/usr/lib/python2.6/site-packages/virtualenv-1.11-py2.6.egg/virtualenv_support/setuptools-2.0.2-py2.py3-none-any.whl/pkg_resources.py", line 1488, in _zipinfo_name
AssertionError: /usr/lib/python2.6/site-packages/virtualenv-1.11-py2.6.egg/EGG-INFO/PKG-INFO is not a subpath of /usr/lib/python2.6/site-packages/virtualenv-1.11-py2.6.egg/virtualenv_support/setuptools-2.0.2-py2.py3-none-any.whl/
----------------------------------------
...Installing setuptools, pip...done.
Traceback (most recent call last):
  File "/usr/bin/virtualenv", line 9, in <module>
    load_entry_point('virtualenv==1.11', 'console_scripts', 'virtualenv')()
  File "/usr/lib/python2.6/site-packages/virtualenv-1.11-py2.6.egg/virtualenv.py", line 820, in main
    symlink=options.symlink)
  File "/usr/lib/python2.6/site-packages/virtualenv-1.11-py2.6.egg/virtualenv.py", line 988, in create_environment
    install_wheel(to_install, py_executable, search_dirs)
  File "/usr/lib/python2.6/site-packages/virtualenv-1.11-py2.6.egg/virtualenv.py", line 956, in install_wheel
    'PIP_NO_INDEX': '1'
  File "/usr/lib/python2.6/site-packages/virtualenv-1.11-py2.6.egg/virtualenv.py", line 898, in call_subprocess
    % (cmd_desc, proc.returncode))
OSError: Command /usr/local/plivo/bin/python -c "import sys, pip; pip...ll\"] + sys.argv[1:])" setuptools pip failed with error code 1
./plivo_install.sh: line 185: /usr/local/plivo/bin/activate: No such file or directory
Wheel installs require setuptools >= 0.8 for dist-info support.
pip's wheel support requires setuptools >= 0.8 for dist-info support.
Storing debug log for failure in /root/.pip/pip.log
Wheel installs require setuptools >= 0.8 for dist-info support.
pip's wheel support requires setuptools >= 0.8 for dist-info support.
Storing debug log for failure in /root/.pip/pip.log



Installation failed !









Please help
fikret
 
Posts: 1
Joined: Mon Jan 06, 2014 10:31 pm

Re: Plivo failing on centos 64

Postby basementclev2 » Tue Apr 01, 2014 2:46 pm

I'm having the same issue with Plivo installation
basementclev2
 
Posts: 3
Joined: Mon Mar 31, 2014 8:10 pm


Return to Installation

Who is online

Users browsing this forum: Google [Bot] and 1 guest