Page 1 of 1

Install ICTCore

PostPosted: Tue Feb 07, 2017 4:05 pm
by mehdi
I am at the middle of installation of ICTFax. I installed all the requirement based on the document.
Right now, I am trying to install the ICTCore with the
Code: Select all
 yum -y install ictcore ictcore-voice ictcore-fax ictcore-email
command but it is giving me the following error.
Please let me know why it is giving me this error and how can I fix it.

Regards,
Mehdi

Code: Select all
[root@fax ~]# yum install ictcore ictcore-voice ictcore-fax ictcore-email
Loaded plugins: fastestmirror, refresh-packagekit, security
Setting up Install Process
Loading mirror speeds from cached hostfile
 * base: mirrors.cat.pdx.edu
 * epel: mirror.us.leaseweb.net
 * extras: mirror.vtti.vt.edu
 * updates: linux.mirrors.es.net
Resolving Dependencies
--> Running transaction check
---> Package ictcore.noarch 0:0.7.4.2-release.el6 will be installed
--> Processing Dependency: php-xmlrpc for package: ictcore-0.7.4.2-release.el6.noarch
--> Processing Dependency: php-xml for package: ictcore-0.7.4.2-release.el6.noarch
--> Processing Dependency: php-posix for package: ictcore-0.7.4.2-release.el6.noarch
--> Processing Dependency: php-pecl-libevent for package: ictcore-0.7.4.2-release.el6.noarch
--> Processing Dependency: php-pecl-imagick for package: ictcore-0.7.4.2-release.el6.noarch
--> Processing Dependency: php-pear-SOAP for package: ictcore-0.7.4.2-release.el6.noarch
--> Processing Dependency: php-pear-Pager for package: ictcore-0.7.4.2-release.el6.noarch
--> Processing Dependency: php-pear-HTTP-Request for package: ictcore-0.7.4.2-release.el6.noarch
--> Processing Dependency: php-mysql for package: ictcore-0.7.4.2-release.el6.noarch
--> Processing Dependency: php-mcrypt for package: ictcore-0.7.4.2-release.el6.noarch
--> Processing Dependency: php-mbstring for package: ictcore-0.7.4.2-release.el6.noarch
--> Processing Dependency: mysql-connector-odbc for package: ictcore-0.7.4.2-release.el6.noarch
--> Processing Dependency: dos2unix for package: ictcore-0.7.4.2-release.el6.noarch
---> Package ictcore-email.noarch 0:0.7.4.2-release.el6 will be installed
--> Processing Dependency: ictcore-gateway-email for package: ictcore-email-0.7.4.2-release.el6.noarch
---> Package ictcore-fax.noarch 0:0.7.4.2-release.el6 will be installed
--> Processing Dependency: ictcore-gateway-fax for package: ictcore-fax-0.7.4.2-release.el6.noarch
--> Processing Dependency: hylafax+-client for package: ictcore-fax-0.7.4.2-release.el6.noarch
---> Package ictcore-voice.noarch 0:0.7.4.2-release.el6 will be installed
--> Running transaction check
---> Package dos2unix.i686 0:3.1-37.el6 will be installed
---> Package hylafax+-client.i686 0:5.5.8-1.el6 will be installed
---> Package ictcore.noarch 0:0.7.4.2-release.el6 will be installed
--> Processing Dependency: php-pecl-libevent for package: ictcore-0.7.4.2-release.el6.noarch
---> Package ictcore-freeswitch.noarch 0:0.7.4.2-release.el6 will be installed
--> Processing Dependency: freeswitch-lua for package: ictcore-freeswitch-0.7.4.2-release.el6.noarch
---> Package ictcore-sendmail.noarch 0:0.7.4.2-release.el6 will be installed
--> Processing Dependency: php-imap for package: ictcore-sendmail-0.7.4.2-release.el6.noarch
---> Package mysql-connector-odbc.i686 0:5.3.7-1.el6 will be installed
---> Package php-mbstring.i686 0:5.3.3-48.el6_8 will be installed
---> Package php-mcrypt.i686 0:5.3.3-5.el6 will be installed
--> Processing Dependency: libmcrypt.so.4 for package: php-mcrypt-5.3.3-5.el6.i686
---> Package php-mysql.i686 0:5.3.3-48.el6_8 will be installed
--> Processing Dependency: php-pdo(x86-32) for package: php-mysql-5.3.3-48.el6_8.i686
---> Package php-pear-HTTP-Request.noarch 0:1.4.4-2.el6 will be installed
--> Processing Dependency: php-pear(Net_URL) >= 1.0.12 for package: php-pear-HTTP-Request-1.4.4-2.el6.noarch
--> Processing Dependency: php-pear(Net_Socket) >= 1.0.7 for package: php-pear-HTTP-Request-1.4.4-2.el6.noarch
---> Package php-pear-Pager.noarch 0:2.4.8-2.el6 will be installed
---> Package php-pear-SOAP.noarch 0:0.12.0-4.el6 will be installed
--> Processing Dependency: php-pear(Net_DIME) for package: php-pear-SOAP-0.12.0-4.el6.noarch
--> Processing Dependency: php-pear(Mail_Mime) for package: php-pear-SOAP-0.12.0-4.el6.noarch
--> Processing Dependency: php-pear(Mail) for package: php-pear-SOAP-0.12.0-4.el6.noarch
---> Package php-pecl-imagick.i686 0:2.2.2-5.el6 will be installed
---> Package php-process.i686 0:5.3.3-48.el6_8 will be installed
---> Package php-xml.i686 0:5.3.3-48.el6_8 will be installed
---> Package php-xmlrpc.i686 0:5.3.3-48.el6_8 will be installed
--> Running transaction check
---> Package freeswitch-lua.i686 0:1.4.26-1.el6 will be installed
---> Package ictcore.noarch 0:0.7.4.2-release.el6 will be installed
--> Processing Dependency: php-pecl-libevent for package: ictcore-0.7.4.2-release.el6.noarch
---> Package libmcrypt.i686 0:2.5.8-9.el6 will be installed
---> Package php-imap.i686 0:5.3.3-48.el6_8 will be installed
--> Processing Dependency: libc-client.so.2007 for package: php-imap-5.3.3-48.el6_8.i686
---> Package php-pdo.i686 0:5.3.3-48.el6_8 will be installed
---> Package php-pear-Mail.noarch 0:1.2.0-1.el6 will be installed
--> Processing Dependency: php-pear(Net_SMTP) >= 1.4.1 for package: php-pear-Mail-1.2.0-1.el6.noarch
---> Package php-pear-Mail-Mime.noarch 0:1.8.4-1.el6 will be installed
---> Package php-pear-Net-DIME.noarch 0:1.0.2-1.el6 will be installed
---> Package php-pear-Net-Socket.noarch 0:1.0.10-1.el6 will be installed
---> Package php-pear-Net-URL.noarch 0:1.0.15-4.el6 will be installed
--> Running transaction check
---> Package ictcore.noarch 0:0.7.4.2-release.el6 will be installed
--> Processing Dependency: php-pecl-libevent for package: ictcore-0.7.4.2-release.el6.noarch
---> Package libc-client.i686 0:2007e-11.el6 will be installed
---> Package php-pear-Net-SMTP.noarch 0:1.6.1-1.el6 will be installed
--> Processing Dependency: php-pear(Auth_SASL) for package: php-pear-Net-SMTP-1.6.1-1.el6.noarch
--> Running transaction check
---> Package ictcore.noarch 0:0.7.4.2-release.el6 will be installed
--> Processing Dependency: php-pecl-libevent for package: ictcore-0.7.4.2-release.el6.noarch
---> Package php-pear-Auth-SASL.noarch 0:1.0.6-1.el6 will be installed
--> Finished Dependency Resolution
Error: Package: ictcore-0.7.4.2-release.el6.noarch (ict)
           Requires: php-pecl-libevent
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Re: Install ICTCore

PostPosted: Wed Feb 08, 2017 4:11 pm
by mehdi
Actually the error message is
Code: Select all
Error: Package: ictcore-0.7.4.2-release.el6.noarch (ict)
           Requires: php-pecl-libevent


If some one knows please help me.

Thanks