outbound fax

Post your configuration issues while installing ictfax

Re: outbound fax

Postby falak » Tue Jul 23, 2013 4:48 am

Did you check the following post link for forcing T.38 faxing?

http://forum.ictfax.org/viewtopic.php?f=12&t=2472&sid=7237d4af5952fb628425f7ef613f9bdf
falak
Site Admin
 
Posts: 166
Joined: Tue Jan 17, 2012 7:33 am

Re: outbound fax

Postby falak » Tue Jul 23, 2013 10:26 am

Your log is OK. It doesn't show any error. It says call completed and HangupCause is NORMAL_CLEARING.

Ringing url (saying Not found) is not handled by the ICTFAX so what ever it says it doesn't have any effect on the output.

Problem may have been somewhere else.

2013-07-23 11:06:24,924 plivo-rest[1213]: ERROR: Sending to POST http://127.0.0.1/ictfax/index.php?q=ict ... _hangup/51 with {'Direction': 'outbound', 'Channel-Read-Codec-Bit-Rate': u'64000', 'From': u'xxxxxxxxxx', 'ALegUUID': u'2461e522-f377-11e2-b5c0-37456a01cea9', 'variable_user_context': '', 'HangupCause': u'NORMAL_CLEARING', 'To': u'xxxxxxxxxx', 'CallUUID': u'2461e522-f377-11e2-b5c0-37456a01cea9', 'ALegRequestUUID': u'246197b6-f377-11e2-9e84-005056a00009', 'RequestUUID': u'246197b6-f377-11e2-9e84-005056a00009', 'CallStatus': 'completed'}
falak
Site Admin
 
Posts: 166
Joined: Tue Jan 17, 2012 7:33 am

Re: outbound fax

Postby falak » Tue Jul 23, 2013 10:42 am

What "fax status" says in the GUI when you send a fax from fax outbox? Is it "in queue" or "sent"?
falak
Site Admin
 
Posts: 166
Joined: Tue Jan 17, 2012 7:33 am

Re: outbound fax

Postby falak » Thu Jul 25, 2013 7:09 am

Your Freeswitch log and Plivo log is not showing any error. That means ICTFax has successfully placed the call and is ready to send the fax. If the fax doesn't transmit, that must be the codec issue.

By default ICTFAX, transmits fax in G.711 (alaw, ulaw). If your provider support T.38, then you should force T.38 faxing in ICTFAX, that is enabled as describe in the following link:

http://forum.ictfax.org/viewtopic.php?f=12&t=2472&sid=c098785aecd71c753ac8c92f318b6d9b

If you are still not able to send fax, then I would suggest to test your gateway by executing following command in FS CLI. In the commands below, "voipinnovations" is the gateway name in freeswitch, and "xxxxxxxxxx" represents fax number to send fax, and "10.tif" is the test fax file that will be sent at the given number. You should place your test fax file in /usr/local/freeswitch/storage folder.

Test T38 faxing:
originate {fax_enable_t38=true,fax_enable_t38_request=true}sofia/gateway/voipinnovations/xxxxxxxxxx &txfax(/usr/local/freeswitch/storage/10.tif)

Test Without T38:
originate sofia/gateway/voipinnovations/xxxxxxxxxx &txfax(/usr/local/freeswitch/storage/10.tif)

If any of these method work, then use that method in ICTFAX. If none of the two worked, then your problem lies in the gateway or codec.
falak
Site Admin
 
Posts: 166
Joined: Tue Jan 17, 2012 7:33 am


Return to Configuration

Who is online

Users browsing this forum: No registered users and 2 guests