Cisco UCM and FreeSwitch

Issues related to Freeswitch

Re: Cisco UCM and FreeSwitch

Postby dokma » Fri Apr 26, 2013 7:40 am

I have Cisco CallManager 4.2(3), and I have configured SIP trunk, for Destiation address put the IP address of ICTFax, transport type UDP, Codec 711ulaw, and it is important that Media Termination Point Required should be ON. All other settings vary from system to system, but if you're testing - leave them with default values, or with empty fields.

Since Cisco CallManager SIP trunk doesn't use authentification you can put whatever values you want (you can leave it as it is here).
But because of how the Freeswitch works, it is important to leave them.

This is my /usr/local/freeswitch/conf/sip_profiles/external/cucm.xml - ICTFax configuration file for Cisco CallManager SIP Trunk:

<include>
<gateway name="cucm">
<param name="username" value="user"/> <--- leave as it is
<param name="password" value="pass"/> <--- leave as it is
<param name="proxy" value="x.x.x.x"/> <-- IP address of your CUCM Server
<param name="register" value="false"/>
<param name="disable-register" value="true"/> <--- I haven't played much with this, but since it works...
<param name="accept-blind-reg" value="true"/> <--- also, perhaps it is not neccessary, but if it works...
</gateway>
</include>

After you finish this, go to the ICTFax admin, in provider trunks you must create new trunk with the same trunk name as .xml file.
dokma
 
Posts: 1
Joined: Wed Apr 24, 2013 1:26 pm

Re: Cisco UCM and FreeSwitch

Postby falak » Tue Jul 08, 2014 9:43 am

In GUI trunk name should be just "cucm".
falak
Site Admin
 
Posts: 166
Joined: Tue Jan 17, 2012 7:33 am


Return to Freeswitch related Issues

Who is online

Users browsing this forum: No registered users and 1 guest