Cisco UCM SIP trunk config

Issues related to Freeswitch

Freeswitch Gateway Config

Postby falak » Fri Apr 26, 2013 9:36 am

As far trunk configuration is concerned, Freeswitch have mandatory username and password fields. In your case since there are no username and password, so you can just write some dummy values for username and password so that Freeswitch does not mark it as an error.

Following could be the gateway trunk configuration in your case.
Code: Select all
<include>
  <gateway name="cucm">
    <param name="username" value="user"/>
    <param name="password" value="pass"/>
    <param name="proxy" value="xxx.xxx.xxx.xxx"/>
    <param name="register" value="false"/>
  </gateway>
</include>



Proxy field above in the gateway requires IP address of your Cisco UCM where it is listening for SIP request. You can optionally choose register value as true or false depending upon your cucm how it handles. Rest of your configurations are fine.

Try it and see what happens.
falak
Site Admin
 
Posts: 168
Joined: Tue Jan 17, 2012 7:33 am

Re: Freeswitch Gateway Config

Postby falak » Fri Apr 26, 2013 9:41 am

ubuntuman wrote:Falak, thank you fro the help. Now I got two different states for the "true" and "False". If I put register to true I got "Wait_Fail" or something like that but if I put register "false" I got "NOREG" state near cucm and our SIP IP.

Is this fine, what to do next?

Also, what about "Fax Number is not valid" or not found. What is the problem?
Guys you are very kind with us, however, you really need to improve the documentations and make things more clear and take out any vague out of it. I hope you'll have time for this.

Documentation and help is the soul of the FOSS world, I think!!

As you write above, this means your gateway is not configured properly if it says "Wait_Fail". Sometimes, however, there is no need to set register to true like in case of VOIPInnovations gateway. And simply setting register to false and status "NOREG" is fine.

As far as, CISCO UCM is concerned, I haven't tried configuring it with Freeswitch before. So I am in no position to tell you whether setting register to true is fine or it works with register status to false also.

First thing you can do to test whether your current configurations are working or not, try calling through your gateway on Freeswitch using following command. This will make it easy for you to test and debug your gateway. Write at command line /usr/local/freeswitch/bin/fs_cli and on the fs console write following:

Code: Select all
originate sofia/gateway/cucm/your_number_to_dial &echo()



Where cucm is name of your gateway in Freeswitch that you configured. Replace your actual phone number in place of "your_number_to_dial" in the line above. If you have done connecting CUCM with Freeswitch, rest is trivial as ICTFAX uses commands similar to above to send / receive fax.

I also recommend you to see the following links to learn more on connecting CISCO UCM and Freeswitch:

http://www.voip-info.org/wiki/view/Conf ... ll+Manager
http://wiki.freeswitch.org/wiki/Cisco_Call_Manager
http://freeswitch-users.2379917.n2.nabb%20...%2027811.html

I also ask other members to share if they have any information or pointers to solve this issue.
falak
Site Admin
 
Posts: 168
Joined: Tue Jan 17, 2012 7:33 am

Re: Freeswitch Gateway Config

Postby falak » Fri Apr 26, 2013 9:42 am

As said before, I haven't done configuration of CUCM with Freeswitch. So I don't really know what is the problem actually. Let's see if any of the member on this forum reply to your post.

ubuntuman wrote:Falak,.

Thanks for the reply and the help. I tried to test as you suggest and type:
originate sofia/gateway/cucm/373 &echo()

I got this:
Socket interrupted, bye!
And Freeswitch just shutdown automatically.

Any idea what is wrong?
falak
Site Admin
 
Posts: 168
Joined: Tue Jan 17, 2012 7:33 am

Re:I CANNOT RECEIVE INCOMING CALL OR FAX

Postby falak » Fri Apr 26, 2013 10:02 am

For receiving a call or fax, you need an inbound DID configured and pointing to your ICTFAX server. Once DID is configured, second thing you need to make sure is that the IP address of calling server (in your case CUCM) must be added/allowed in ACL domains of Freeswitch.

To see and debug further with the log of FreeSwitch, write following at the shell
# /usr/local/freeswitch/bin/fs_cli

Hope it might help you.
falak
Site Admin
 
Posts: 168
Joined: Tue Jan 17, 2012 7:33 am

Re:I CANNOT RECEIVE INCOMING CALL OR FAX

Postby falak » Fri Apr 26, 2013 10:03 am

Yes, Sendmail server is the required if you want to "send fax via email". The whole procedure is described in the guide. However, Sendmail is not required for "receiving and incoming fax at email address". But it is recommended to use in both scenarios.

Following link might help you.
viewtopic.php?f=6&t=2377

good luck.
falak
Site Admin
 
Posts: 168
Joined: Tue Jan 17, 2012 7:33 am

Re: PROBLEM FORWARD RECEIVING FAX TO EMAIL

Postby falak » Fri Apr 26, 2013 10:06 am

You first install ICTFAX at some server that is accessible through a public IP address or domain. Let's say you installed ICTFAX at a server with IP address xxx.xxx.xxx.xxx. Now if any user access this server (using xxx.xxx.xxx.xxx in his browser) and try to register an account, he will receive an email with IP address xxx.xxx.xxx.xxx.

That means if you access your system through localhost to create an account, you will receive an email for account registration with 127.0.0.1 IP address. So first configure your server with some public IP or domain. Then access your ICTFAX installation through that domain or IP. You might not see this problem.
falak
Site Admin
 
Posts: 168
Joined: Tue Jan 17, 2012 7:33 am

Re: PROBLEM FORWARD RECEIVING FAX TO EMAIL

Postby falak » Fri Apr 26, 2013 10:07 am

when the user receive a fax in his inbox, i get the same problem, it's not possible to view the fax in other web access computer cause his inbox point on localhost. i want to point it to the address 10.6.2.22, but i dont know where to change that.
127.0.0.1/ictfax/sites/default/files/ictfax/inbox/3.pdf



Inbox file access URL can be changed by logging-in as admin. Then go to ICTFAX System -> Application Path Settings. Then inbox fax directory web address accordingly.

As far as DID is concerned, make sure DID is pointing to a single user only. (No multiple user with same DID)

Hope it might resolve your problems.
falak
Site Admin
 
Posts: 168
Joined: Tue Jan 17, 2012 7:33 am

Re: PROBLEM FORWARD RECEIVING FAX TO EMAIL

Postby falak » Fri Apr 26, 2013 10:10 am

If your sendmail server is working fine, then there is a hack for your to send your emails through sendmail.

Go to your ICTFAX installation directory. Open file in sites/all/modules/ictpbx/ictfax/ictfax.module.

Find in this file the following line (written at around line number 1350):

Code: Select all
if (!(variable_get('smtp_library', '') && file_exists(variable_get('smtp_library', '')))) {


Code: Select all
if (false) {




This will force to use sendmail for sending emails bypassing SMTP library.

Hope it will do the trick for you.
falak
Site Admin
 
Posts: 168
Joined: Tue Jan 17, 2012 7:33 am

PROBLEM RECEIVE FAX TO AN EXTERNAL MAIL SERVER

Postby falak » Fri Apr 26, 2013 10:15 am

Usually there could be some problem while generating PDF from TIFF file. A received fax is a TIFF file that is converted to PDF and then sent as an attachment with email. First thing that you can ensure is to check that received TIFF file has been correctly received or not. Your received files will be placed in ictfax/sites/default/files/ictfax/inbox directory. Then check your PDF file in the same directory. If you could not find a PDF file that means it has not been converted successfully. This is the main reason for a blank attachment file.

Let me know if this is the problem?
falak
Site Admin
 
Posts: 168
Joined: Tue Jan 17, 2012 7:33 am


Return to Freeswitch related Issues

Who is online

Users browsing this forum: No registered users and 1 guest