outbound faxes dont send "No XML Response"

Issues related to Freeswitch

outbound faxes dont send "No XML Response"

Postby odge » Mon Sep 16, 2013 4:23 pm

my faxes dont send, what else can i look at to try debug the issue?

My outbound log shows:

2013-09-16 17:34:31,751 plivo-outbound[23003]: INFO: (1) Requested RESTXML to http://127.0.0.1/ictfax/index.php?q=ictfax/send_fax/18
2013-09-16 17:34:31,751 plivo-outbound[23003]: WARNING: (1) No XML Response

and My Rest log shows:

2013-09-16 17:34:29,020 plivo-rest[22993]: DEBUG: Waiting Call attempt for RequestUUID 79bd1598-1ee5-11e3-9f38-005056af1e97 ...
2013-09-16 17:34:29,904 plivo-rest[22993]: DEBUG: Notify Call success (Ringing) for RequestUUID 79bd1598-1ee5-11e3-9f38-005056af1e97
2013-09-16 17:34:29,904 plivo-rest[22993]: INFO: Call from 2741xxxxxxx to 08xxxx0436 Ringing for RequestUUID 79bd1598-1ee5-11e3-9f38-005056af1e97
2013-09-16 17:34:29,907 plivo-rest[22993]: INFO: Call Attempt OK for RequestUUID 79bd1598-1ee5-11e3-9f38-005056af1e97
2013-09-16 17:34:29,907 plivo-rest[22993]: INFO: Fetching POST http://127.0.0.1/ictfax/index.php/ringing/ with {'To': u'08xxxx0436', 'Direction': u'outbound', 'From': u'2741xxxxxxx', 'variable_duration': '', 'CallUUID': u'79bd8140-1ee5-11e3-9c8a-85855a749bc4', 'RequestUUID': u'79bd1598-1ee5-11e3-9f38-005056af1e97', 'CallStatus': 'ringing'}
2013-09-16 17:34:30,133 plivo-rest[22993]: ERROR: Sending to POST http://127.0.0.1/ictfax/index.php/ringing/ with {'Direction': u'outbound', 'From': u'2741xxxxxxx', 'To': u'08xxxx0436', 'variable_duration': '', 'RequestUUID': u'79bd1598-1ee5-11e3-9f38-005056af1e97', 'CallUUID': u'79bd8140-1ee5-11e3-9c8a-85855a749bc4', 'CallStatus': 'ringing'} -- Error: HTTP Error 404: Not Found
2013-09-16 17:34:31,454 plivo-rest[22993]: DEBUG: Notify Call success (EarlyMedia) for RequestUUID 79bd1598-1ee5-11e3-9f38-005056af1e97
2013-09-16 17:34:31,777 plivo-rest[22993]: DEBUG: Notify Call success for RequestUUID 79bd1598-1ee5-11e3-9f38-005056af1e97
2013-09-16 17:34:31,778 plivo-rest[22993]: INFO: Hangup for Outgoing CallUUID 79bd8140-1ee5-11e3-9c8a-85855a749bc4 Completed, HangupCause NORMAL_CLEARING, RequestUUID 79bd1598-1ee5-11e3-9f38-005056af1e97
2013-09-16 17:34:31,778 plivo-rest[22993]: DEBUG: Call Cleaned up for RequestUUID 79bd1598-1ee5-11e3-9f38-005056af1e97
2013-09-16 17:34:31,778 plivo-rest[22993]: DEBUG: Extra params found in url query for POST http://127.0.0.1/ictfax/index.php?q=ict ... _hangup/18
2013-09-16 17:34:31,779 plivo-rest[22993]: INFO: Fetching POST http://127.0.0.1/ictfax/index.php?q=ict ... _hangup/18 with {'Direction': 'outbound', 'From': u'2741xxxxxxx', 'ALegUUID': u'79bd8140-1ee5-11e3-9c8a-85855a749bc4', 'HangupCause': u'NORMAL_CLEARING', u'q': u'ictfax/send_fax_hangup/18', 'To': u'08xxxx0436', 'variable_duration': u'3', 'RequestUUID': u'79bd1598-1ee5-11e3-9f38-005056af1e97', 'ALegRequestUUID': u'79bd1598-1ee5-11e3-9f38-005056af1e97', 'CallUUID': u'79bd8140-1ee5-11e3-9c8a-85855a749bc4', 'CallStatus': 'completed'}
2013-09-16 17:34:32,037 plivo-rest[22993]: ERROR: Sending to POST http://127.0.0.1/ictfax/index.php?q=ict ... _hangup/18 with {'Direction': 'outbound', 'From': u'2741xxxxxxx', 'ALegUUID': u'79bd8140-1ee5-11e3-9c8a-85855a749bc4', 'HangupCause': u'NORMAL_CLEARING', 'To': u'08xxxx0436', 'variable_duration': u'3', 'CallUUID': u'79bd8140-1ee5-11e3-9c8a-85855a749bc4', 'ALegRequestUUID': u'79bd1598-1ee5-11e3-9f38-005056af1e97', 'RequestUUID': u'79bd1598-1ee5-11e3-9f38-005056af1e97', 'CallStatus': 'completed'} -- Error: HTTP Error 403: Forbidden
odge
 
Posts: 1
Joined: Mon Sep 16, 2013 4:00 pm

Re: outbound faxes dont send "No XML Response"

Postby nasir » Wed Sep 18, 2013 8:05 am

Drupal admin reports and apache logs may help, further please let us know about version of ICTFAX you are using (latest is trunk at github)
nasir
 
Posts: 55
Joined: Mon Sep 09, 2013 12:11 pm

Re: outbound faxes dont send "No XML Response"

Postby mkay » Thu Oct 10, 2013 1:12 pm

nasir wrote:Drupal admin reports and apache logs may help, further please let us know about version of ICTFAX you are using (latest is trunk at github)


I have same problem. I have ICTFAX ver. 2.1.1. In log are same sessions. When I try send fax from FS_cli command - "originate sofia/gateway/gateway_name/phone_number &txfax(/tmp/fax.tif)"
- fax sending working perfectly, but when i try to send fax with ictfax (web aplication) : ringing is ok, but after answered from second side, call after >1 second (cca. 500ms) ended. Just for info - second side (my provider) supported only codec G.711a. My provider don´t have support for T.38 . Pls help . :(

just I add info : from the SIP log from second side, call first ended ICTFAX - cause Bye after 200 OK.
mkay
 
Posts: 4
Joined: Thu Oct 10, 2013 12:46 pm

Re: outbound faxes dont send "No XML Response"

Postby nasir » Fri Oct 11, 2013 6:37 am

recently we have made few changes regarding this issue, please get latest code from github master branch, and update your installation accordingly. (remember to check your plivo url settings if it match as mentioned in installation guide)
nasir
 
Posts: 55
Joined: Mon Sep 09, 2013 12:11 pm

Re: outbound faxes dont send "No XML Response"

Postby mkay » Fri Oct 18, 2013 8:04 am

Thanks for your help. Now all works OK :)
mkay
 
Posts: 4
Joined: Thu Oct 10, 2013 12:46 pm


Return to Freeswitch related Issues

Who is online

Users browsing this forum: No registered users and 1 guest

cron