Plivo problem - Sending Faxes -

Issues related to Freeswitch

Plivo problem - Sending Faxes -

Postby froque » Tue Oct 21, 2014 6:22 pm

Hi, I am having trouble sending fax.

When looking at /usr/local/plivo/tmp/plivo-outbound.log file I am seeing this error :

2014-10-21 12:14:47,030 plivo-outbound[29395]: INFO: (7) Requested RESTXML to http://127.0.0.1/ictfax/index.php?q=ictfax/send_fax/6

2014-10-21 12:14:47,030 plivo-outbound[29395]: ERROR: (7) Processing Call Failure !
2014-10-21 12:14:47,030 plivo-outbound[29395]: ERROR: (7) Unrecognized Element: ['SendFax']





2014-10-21 12:14:47,031 plivo-outbound[29395]: ERROR: (7) Traceback (most recent call last):
2014-10-21 12:14:47,031 plivo-outbound[29395]: ERROR: (7) File "/usr/local/plivo/src/plivo/src/plivo/rest/freeswitch/outboundsocket.py", line 463, in _run
2014-10-21 12:14:47,031 plivo-outbound[29395]: ERROR: (7) self.process_call()
2014-10-21 12:14:47,031 plivo-outbound[29395]: ERROR: (7) File "/usr/local/plivo/src/plivo/src/plivo/rest/freeswitch/outboundsocket.py", line 500, in process_call
2014-10-21 12:14:47,031 plivo-outbound[29395]: ERROR: (7) self.lex_xml()
2014-10-21 12:14:47,031 plivo-outbound[29395]: ERROR: (7) File "/usr/local/plivo/src/plivo/src/plivo/rest/freeswitch/outboundsocket.py", line 599, in lex_xml
2014-10-21 12:14:47,031 plivo-outbound[29395]: ERROR: (7) % invalid_element)
2014-10-21 12:14:47,031 plivo-outbound[29395]: ERROR: (7) UnrecognizedElementException: Unrecognized Element: ['SendFax']
2014-10-21 12:14:47,031 plivo-outbound[29395]: INFO: (7) Processing Call Ended
2014-10-21 12:14:47,031 plivo-outbound[29395]: DEBUG: (7) Releasing Connection ...
2014-10-21 12:14:49,031 plivo-outbound[29395]: DEBUG: (7) Releasing Connection Done
2014-10-21 12:14:49,031 plivo-outbound[29395]: INFO: (7) End request from ('127.0.0.1', 55125)


I followed step by step this instructions:

http://ictfax.org/content/ictfax-instal ... tos-fedora

Can you help me with this problem?

Thanks for all

Francisco
froque
 
Posts: 4
Joined: Tue Oct 21, 2014 6:05 pm

Re: Plivo problem - Sending Faxes -

Postby falak » Wed Oct 22, 2014 11:40 am

You probably need to install Plivo again because your error log say SendFax unrecognized element. This happens when fax related functionality is not properly configured during plivo installation. Before installation again, make sure you stop and remove plivo from your /usr/local folder completely.
falak
Site Admin
 
Posts: 168
Joined: Tue Jan 17, 2012 7:33 am

Re: Plivo problem - Sending Faxes -

Postby froque » Wed Oct 22, 2014 12:30 pm

Hi falak, thanks for your answer. I will install again plivo.
froque
 
Posts: 4
Joined: Tue Oct 21, 2014 6:05 pm

Re: Plivo problem - Sending Faxes -

Postby froque » Wed Oct 22, 2014 12:49 pm

Reinstalled plivo, and reconfigured with these indications:

Plivo Configurations:

1. Go to /usr/local/plivo/etc/plivo/default.conf
2. Enable EXTRA_FS_VARS by removing # before it.
3. Set variable in plivo config as EXTRA_FS_VARS = variable_duration
4. Set Incoming DEFAULT_ANSWER_URL, DEFAULT_HANGUP_URL

DEFAULT_ANSWER_URL = http://127.0.0.1/ictfax/index.php?q=ictfax/receive_fax
DEFAULT_HANGUP_URL = http://127.0.0.1/ictfax/index.php?q=ict ... email/post

Modify above urls according to your installation settings.
Don't forget to remove “#” sign before DEFAULT_HANGUP_URL and EXTRA_FS_VARS.




but the problem continues

2014-10-22 06:59:49,884 plivo-outbound[26967]: INFO: (1) Requested RESTXML to http://127.0.0.1/ictfax/index.php?q=ictfax/send_fax/9
2014-10-22 06:59:49,884 plivo-outbound[26967]: ERROR: (1) Processing Call Failure !
2014-10-22 06:59:49,884 plivo-outbound[26967]: ERROR: (1) Unrecognized Element: ['SendFax']
froque
 
Posts: 4
Joined: Tue Oct 21, 2014 6:05 pm

Re: Plivo problem - Sending Faxes -

Postby froque » Wed Oct 22, 2014 1:14 pm

For inbound calls, the problem is the same:

2014-10-22 07:25:19,759 plivo-outbound[26967]: ERROR: (3) Processing Call Failure !
2014-10-22 07:25:19,759 plivo-outbound[26967]: ERROR: (3) Unrecognized Element: ['ReceiveFax']


There may be some step that is not explicit in the manual? (here: http://ictfax.org/content/ictfax-instal ... tos-fedora)
froque
 
Posts: 4
Joined: Tue Oct 21, 2014 6:05 pm

Re: Plivo problem - Sending Faxes -

Postby falak » Sat Nov 01, 2014 11:46 am

The issues that you mentioned were due to Plivo framework's incompatibility with Faxing.

Now Latest ICTFAX is available for download from github and sourceforge. Plivo framework has been removed from ICTFAX and newly developed ICTCore now acts a communication library between ICTFAX and FreeSWITCH. Please use the installation and administration documentation from github. We are in the process of updating documents at the ictfax website.
falak
Site Admin
 
Posts: 168
Joined: Tue Jan 17, 2012 7:33 am


Return to Freeswitch related Issues

Who is online

Users browsing this forum: No registered users and 0 guests

cron