Problem with fresh new install, help please!  [SOLVED]

Post queries and issues that you found during ictfax installation

Problem with fresh new install, help please!

Postby wizwareinc » Fri Nov 07, 2014 12:53 am

Installed clean new CentOS 6 minimal install, followed the directions on http://ictfax.org/content/ictfax-instal ... tos-fedora.

Following installation of ICTCore Module, when trying to log off and back on the site, I get this right after logon:

------------------------
"Recoverable fatal error: Object of class stdClass could not be converted to string in DatabaseStatementBase->execute() (line 2171 of /usr/ictfax/includes/database/database.inc)."

Error
The website encountered an unexpected error. Please try again later.
------------------------

I can install all the ICTCore System Modules except the 'ICTCore Module' and everything is fine. But as soon as I install that module, can no longer log in. Can someone please help direct me to a solution for this? I have wiped and reinstalled over 5 times now and can't get past this step.
wizwareinc
 
Posts: 1
Joined: Fri Nov 07, 2014 12:45 am

Re: Problem with fresh new install, help please!

Postby nasir » Fri Nov 07, 2014 3:35 pm

There was an issue with ictpbx/ictcore/ictcore.module, which we have just fixed! now you need to update this file in your installation.

you can get updated code from here https://raw.githubusercontent.com/ictin ... ore.module
nasir
 
Posts: 55
Joined: Mon Sep 09, 2013 12:11 pm

Re: Problem with fresh new install, help please!

Postby nasir » Thu Nov 20, 2014 2:42 pm

First of all sorry, to delaying it so long.
After that I will be thankful to mandrei and wizwarinc for bug reporting, and my special thanks to TheDarkNomad for really helping us with the source modifications.

Now I am happy to inform you all, that we have fixed all above reported and many other bugs in ICTFAX repository and in ICTCore rpm.

Thanks
nasir
 
Posts: 55
Joined: Mon Sep 09, 2013 12:11 pm

Re: Problem with fresh new install, help please!

Postby nasir » Fri Jan 16, 2015 5:50 pm

Hi mandrel,

We have just updated our repo with latest ictcore (bug fix release). please update your ictcore installation with yum. as following

Code: Select all
yum update ictcore ictcore-email ictcore-fax


hope it will fix your problem
nasir
 
Posts: 55
Joined: Mon Sep 09, 2013 12:11 pm


Return to Installation

Who is online

Users browsing this forum: No registered users and 1 guest

cron